Feel free to join the next Helmholtz Hacky Hour #26 on Wednesday, April 21, 2021 from 2PM to 3PM!

Commit befd08a9 authored by Martin Lange's avatar Martin Lange

added download links for Java, Gradle, Git and Yarner.

parent 3045afde
Pipeline #12135 passed with stage
in 12 seconds
......@@ -137,7 +137,7 @@ public class IsSearching extends com.artemis.Component {}
> Resources are "things" that exist only once in the model, contrary to entities, and are potentially available for all submodels. Any instance of a Java class can become a resource. However, only one instance of each class is possible.
Grassers live in a two-dimensional world. The world is represented by a grid of grass the grassers can consume.
Grassers live in a two-dimensional world. The world is represented by a grid of grass that grassers can consume.
```java
/// file:src/main/java/grassing/res/Grass.java
......
......@@ -17,7 +17,7 @@ After following any of the following sections, you should see a window with gras
The [downloads](https://git.ufz.de/oesa/ecs-tutorial/-/jobs/artifacts/master/download?job=build) contain a file `Grassing.zip`. Extract it and navigate into folder `Grassing/bin`. Double-click or run file `Grassing` (or `Grassing.bat` if you are on Windows).
> This required Java 11 or newer to be installed on your machine. Simply try running the model, and install Java in case you get a respective error.
> This required [Java](https://www.java.com) 11 or newer to be installed on your machine. Simply try running the model, and install Java in case you get a respective error. Download Java [here](https://www.oracle.com/de/java/technologies/javase-downloads.html) or [here](https://adoptopenjdk.net/) (OpenJDK).
## Browse the plain Java code
......@@ -35,7 +35,7 @@ You can build and run the project with the following command executed inside fol
gradle run
```
> This requires Gradle and Java 11 or newer to be installed on your machine.
> This requires Gradle and Java JDK 11 or newer to be installed on your machine. Download Java [here](https://www.oracle.com/de/java/technologies/javase-downloads.html) or [here](https://adoptopenjdk.net/) (OpenJDK), and Gradle [here](https://gradle.org/releases/).
## Clone, extract, build
......@@ -45,7 +45,7 @@ Clone the repository using the following command:
git clone https://git.ufz.de/oesa/ecs-tutorial.git
```
> This required [Git](https://git-scm.com/) to be installed on your machine.
> This required [Git](https://git-scm.com/) to be installed on your machine. Download Git [here](https://git-scm.com/downloads).
Navigate into the project and run [Yarner](https://github.com/mlange-42/yarner):
......@@ -54,7 +54,7 @@ cd ecs-tutorial
yarner
```
> This requires [Yarner](https://github.com/mlange-42/yarner) to be installed on your machine. Yarner needs to be on the PATH, or you need use the full path to Yarner:
> This requires [Yarner](https://github.com/mlange-42/yarner) to be installed on your machine. Download Yarner [here](https://github.com/mlange-42/yarner/releases/). Yarner needs to be on the PATH, or you need use the full path to Yarner:
>
> ```
> C:/path/to/yarner/yarner
......@@ -67,4 +67,4 @@ cd code
gradle run
```
> This requires Gradle and Java 11 or newer to be installed on your machine.
> This requires Gradle and the Java JDK 11 or newer to be installed on your machine. Download Java [here](https://www.oracle.com/de/java/technologies/javase-downloads.html) or [here](https://adoptopenjdk.net/) (OpenJDK), and Gradle [here](https://gradle.org/releases/).
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment